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C H A P T E R  2 0

Digital Photos

The PC has become an increasingly useful tool in the field of photography. In fact, these 

days it’s hard to find a professional photographer who doesn’t use a computer in some 

way, either to download digital camera images or to scan in images taken using traditional 

film-based cameras.

Ubuntu includes several photo manipulation and cataloging tools. Chief among these is 

a professional-level image-editing program called GIMP (for GNU Image Manipulation 

Program). This chapter introduces this jewel in the crown of Linux software, but first discusses 

how to use the F-Spot photo manager software to import and manage your image collection.

Downloading and Cataloging Images
Before you can undertake any image editing, you need to transfer the images to your PC. 

Depending on the source of the pictures, there are a variety of methods of doing this, but 

in nearly every case, the work of importing your photos is handled by F-Spot. But before 

we cover F-Spot, let’s briefly recap the various methods of transferring images to your PC, 

some of which were outlined in Chapter 8.

Connecting Your Camera

Most modern cameras use memory cards to store the pictures. If you have such a model, 

when you plug the camera into your PC’s USB port, you should find that Ubuntu instantly 

recognizes it. An icon should appear on the desktop, and double-clicking it should display 

the memory card’s contents in a Nautilus window. Along the top of the window, you’ll see an 

orange bar saying “This media contains digital photos” alongside a button marked "Open 

F-Spot Photo Manager”.  Clicking this button will start F-Spot, with which you can copy the 

images to your hard disk, as explained in the next section. Of course, you can simply copy 

the pictures to your hard disk manually using Nautilus. 
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If your camera doesn’t appear to be recognized by Ubuntu, you should consider buying 

a USB card reader. These devices are typically inexpensive and usually can read a wide 

variety of card types, making them a useful investment for the future. Some new PCs even 

come with card readers built in. Most generic card readers should work fine under Linux, 

as will most new digital cameras. 

■Caution  Before detaching your camera or removing a photo card, you should right-click the desktop icon 

and select Unmount Volume. This tells Ubuntu that you’ve finished with the device. Failing to eject in this way 

could cause data errors. 

If you’re working with print photos, negative film, or transparencies, you can use a 

scanner and the XSane program (Applications ➤ Graphics ➤ XSane Image Scanner) to 

digitize them, as explained in Chapter 8. This works in a virtually identical way to the 

TWAIN modules supplied with Windows scanners, in that you need to set the resolution 

in dots per inch (DPI), as well as the color depth. Generally speaking, 300 DPI and 24-bit 

color should provide an adequate representation of most printed photos. Because of their 

smaller size, transparency or negative film images will require higher resolutions, in the 

order of 1,200 or 2,400 DPI.

Importing Photos Using F-Spot

F-Spot is styled after image-cataloging programs you might have used under Windows or 

Macintosh, such as iPhoto or Picasa. Once you run F-Spot (Applications ➤ Graphics ➤ 

F-Spot Photo Manager), or after you click the Open F-Spot Photo Manager button that 

appears along the top of a Nautilus file browser window when you insert a memory card 

or attach your digital camera, the F-Spot Import window will appear. (Depending on your 

configuration, the Import window may appear within a file browser.)

The Import window contains a preview of the pictures stored in your camera, the 

option to tag the pictures, and the target directory where the photos will be copied. By 

default, all of the pictures are selected. You can deselect and select photos using the standard 

selection techniques (Ctrl-click or Shift-click). Embedded tags are very useful in filtering 

and searching for pictures, as discussed in the “Tagging Images” section a little later in the 

chapter. The default target directory where the photos will be copied is Photos in your 

home directory, but you can change it to any directory you prefer.

To import the pictures from your camera to your hard disk, just click the Import button. 

F-Spot will import your photos in the target location, in directories named after the year, 

month, and day the photos were originally taken.
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Importing pictures from your previous Windows setup is easy. Click File ➤ Import. In 

the Import window, click the Import Source drop-down list, and then click Select Folder. 

Using the file browser, navigate to the Windows directory containing your images, and 

then click OK. (Don’t double-click the directory, because this will cause F-Spot to open 

the directory in the file browser.) After you’ve selected the folder, F-Spot will present 

thumbnail previews of the images, and this might take some time. Keep your eye on the 

orange status bar. Once this reads “Done Loading,” you can click the Import button to 

import all the images, or Ctrl-click to select photos in the left side of the window, and then 

click the Import button. As with photos from a camera, by default, F-Spot copies the images 

into a directory it creates within your /home directory, called Photos. Therefore, once you’ve 

imported the photos, you can delete the originals from the Windows partition if you wish. 

■Tip  The Import window can be resized by clicking and dragging its edges. This can be very useful when 

importing many photographs at one time.

Once the photos have been imported, the main F-Spot window will appear. On the left 

are the default tags. On the right is the picture preview window, which can be set to either 

Browse or Edit Photo mode. You can switch between these two modes using the buttons 

on the toolbar. You can also view an image full screen or start a slide show that will cycle 

through the images in sequence. 

Above the picture window is the timeline. By clicking and dragging the slider, you can 

move backward and forward in the photograph collection, depending on when the pictures 

were taken. Each notch on the timeline represents a month within the year marked beneath 

the timeline. The graphs on the timeline give a general idea of how many photographs 

were taken during that particular month (or, indeed, if any were taken during a particular 

month).

Tweaking Photos

By either double-clicking an image or selecting an image and clicking Edit Photo on the 

toolbar, you can tweak images by cropping them, adjusting brightness and contrast, or 

setting the color saturation/balance. In addition, you can convert images to black and 

white or sepia tone, and you can remove red-eye caused by an indoor flash. All of this can 

be achieved by clicking the buttons under the image. (Hovering the mouse cursor over an 

icon will cause a tooltip to appear, explaining what the button does.) Changes to the image 

are made live, as shown in Figure 20-1, so it’s a good idea to drag the dialog box out of the 

way to allow full viewing of the image underneath. 
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Figure 20-1. Any edits to the image are made live, so it’s a good idea to move the adjustment 

dialog box out of the way.

You can also add a comment in the text field below the image. This will then be attached 

to the image for future reference, and can act as a useful memory aid. 

A note of caution is required when tweaking images with F-Spot. Once changes have 

been made, there doesn’t appear to be any way of undoing them. The Edit menu lacks an 

Undo option, and pressing Ctrl+Z doesn’t do anything. However, F-Spot keeps a copy of 

the original image alongside the modified one. To access the original unedited image, 

click File ➤ Version ➤ Original.

■Tip  By clicking File ➤ Create New Version, the currently selected image will be copied and made available 

on the File ➤ Version menu. You can do this as many times as you want, perhaps to record various image 

tweaks to choose the best later. 
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Tagging Images

F-Spot’s cataloging power comes from its ability to tag each image. A tag is simply a word 

or short phrase that can be attached to any number of images, rather like a real-life tag 

that you might find attached to an item in a shop. Once images have been tagged, you can 

then filter the images using the tag word. For example, you could create a tag called German 

vacation, which you would attach to all images taken on a trip to Germany. Then, when 

you select the German vacation tag, only those images will be displayed. Alternatively, you 

could be more precise with tags—you could create the tags Dusseldorf and Cologne to 

subdivide pictures taken on the vacation. 

If your collection involves a lot of pictures taken of your children at various stages 

during their lives, you could create a tag for each of their names. By selecting to view only 

photos tagged with a particular child’s name, you could see all the pictures of that child, 

regardless of when or where they were taken.

Images can have more than one tag. A family photo could be tagged with the words 

thanksgiving, grandma's house, family meal, and the names of the individuals pictured. 

Then, if you searched using any of the tags, the picture would appear in the list. 

A handful of tags are provided by default: Favorites, Hidden, People, Places, and Events. To 

create your own tags, right-click under the tag list on the left of the F-Spot program window 

and select Create New Tag. Simply type in the name of the new tag in the dialog box and 

click OK. 

■Note  Tags can have “parents,” which can help organize them, but we wouldn’t recommend this unless 

you have a great many tags.

Tags can also have icons attached to them. A tag will automatically assign an icon based 

on the first photo it’s assigned to, but to manually assign a tag an icon, right-click it in the 

list and select Edit. Next, in the Edit Tag dialog box, click the icon button, and select from 

the list of icons under the Predefined heading.

To attach a tag to a picture, simply right-click it (in either the Browse or Edit Photo 

mode), and click its entry on Attach Tag. 

To filter by tag, double-click the tag in the tag list, as shown in Figure 20-2. To remove 

the filtering, right-click the tag in the orange bar at the top of the display and select Remove 

from Search.
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Figure 20-2. To filter images by tag, double-click the tag in the list on the left. 

Image Editing Using GIMP
GIMP is an extremely powerful image editor that offers the kind of functions usually associ-

ated with top-end software like Adobe Photoshop. Although GIMP is not aimed at beginners, 

those new to image editing can get a lot from it, provided they put in a little work.

The program relies on a few unusual concepts within its interface, which can catch 

many people off guard. The first of these is that each of the windows within the program, 

such as floating dialog boxes or palettes, gets its own panel entry. In other words, the 

GIMP’s icon bar, image window, settings window, and so on have their own buttons on 

the Ubuntu desktop panel alongside your other programs, as if they were separate programs.
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■Note  GIMP’s way of working is referred to as a Single Document Interface, or SDI. It’s favored by a handful 

of programs that run under Linux and seems to be especially popular among programs that let you create things.

Because of the way that GIMP runs, before you start up the program, it’s a wise idea to 

switch to a different virtual desktop (virtual desktops are discussed in Chapter 7), which 

you can then dedicate entirely to GIMP. 

Click Applications ➤ Graphics ➤ GNU Image Manipulation Program to run GIMP. 

You’ll be greeted by what appears to be a complex assortment of program windows. 

Now you need to be aware of a second unusual aspect of the program: its reliance on 

right-clicking. Whereas right-clicking usually brings up a context menu offering a handful 

of options, within GIMP, it’s the principal way of accessing the program’s functions. Right-

clicking an image brings up a menu offering access to virtually everything you’ll need 

while editing. Ubuntu includes the latest version of GIMP, 2.4, and this features a menu 

bar in the main image-editing window. This is considered sacrilege by many traditional 

GIMP users, although it’s undoubtedly useful for beginners. However, the right-click 

menu remains the most efficient way of accessing GIMP’s tools.

The main toolbar window, shown in Figure 20-3, is on the left. This can be considered 

the heart of GIMP, because when you close it, all the other program windows are closed, 

too. The menu bar on the toolbar window offers most of the options you’re likely to use to 

start out with GIMP. For example, File ➤ Open will open a browser dialog box in which 

you can select files to open in GIMP. It’s even possible to create new artwork from scratch 

by choosing File ➤ New.

■Tip  To create vector artwork, a better choice is a program like Inkscape (www.inkscape.org), which 

can be downloaded via Synaptic Package Manager (to learn about software installation, see Chapter 28).

Beneath the menu bar in the main toolbar window are the tools for working with 

images. Their functions are described in Table 20-1, which lists the tools in order from left 

to right, starting at the top left.
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Figure 20-3. GIMP’s main toolbar window

Table 20-1. GIMP Image-Editing Tools

Tool Description of Use

Rectangle Select Click and drag to select a rectangular area within the image. This selected 
area can then be copied and pasted into a different part of the image or 
turned into a new layer.

Ellipse Select Create an oval or circular selection area within the image, which you 
can then copy and paste.

Free Select Click and draw with the mouse to create a hand-drawn selection area. 
Your selection should end where it started. If not, GIMP will draw a 
straight line between the start and end of the selection.
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Fuzzy Select Known as the “magic wand” in other image editors, this tool creates 
a selection area based on the color of the pixels where you click. For 
example, clicking a red car hood will select most, if not all of the hood, 
because it is mostly red.

Select by Color Works like the Fuzzy Select tool, but will create a selection across the 
entire image based on the color you select. In other words, selecting a 
black T-shirt will also select a black signpost elsewhere in the picture if 
the hues are similar.

Scissors Select Another “magical” tool that lets you create a selection by clicking on 
various points within an image, with the program joining the points 
together based on the color differences between the two points. This 
means that you can select the outline of a car by clicking a few points 
around the edge of the car and, provided the color of the car is different 
from the background, GIMP will work out the color differences and 
select the car’s shape automatically.

Foreground Select Lets you automatically create an intricate selection of an object in the 
foreground of a picture, via a three-step process. Click to draw roughly 
around the foreground object as with the Free Select tool. (Be careful 
you don’t stray into the object; if you do, momentarily select a different 
tool, which will cancel the selection, and try again.) Then release the 
mouse button and draw across the main areas of the object using a 
kind of paintbrush tool. For example, if the object is a face, draw a little 
on the skin and hair. The trick is to cover areas that have different color 
ranges, because that’s how GIMP detects the edges. You’ll see that the 
background—the area that won’t be selected—is masked out in blue 
tint. If any of the foreground object is masked, draw on it to add it 
to the selection area. You can subtract from the selection area by 
Ctrl-clicking. Once you’re happy with the selection, hit Enter.

Paths Draws Bezier curves in order to create paths, which are akin to selections 
and can be saved for use later on in the image-editing process. Just 
click and drag to draw a curve. Each extra click you make will define a 
new curve, which will be joined to the last one. To turn the path into a 
selection, click the button at the bottom of the toolbar.

Color Picker Lets you see the RGB, HSV, or CMYK values of any color within the 
image. Simply click the mouse within the image.

Zoom Click to zoom into the image, right-click to see various zoom options, 
and hold down the Alt key while clicking to zoom out.

Measure Measures distances between two points (in pixels) and also angles. Just 
click and drag to use it. The measurements will appear at the bottom of 
the image window.

Move Click and drag to move any selection areas within the image, as well as 
rearrange the positioning of various layers.

Table 20-1. GIMP Image-Editing Tools (Continued)

Tool Description of Use
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Alignment Allows you to align layers to other objects relative to each other. To choose 
a layer, click an object within the preferred layer. To select several layers, 
Shift-click objects inside the preferred layers. In the tool options of the 
Alignment tool, select how the layer or layers will be aligned relative to 
other layers or image objects. Alignment includes left, center horizontal, 
right, top, center vertical, and bottom, with an option to use offsets 
as well. 

Crop Click and drag to define an area of the image to be cropped. Anything 
outside the selection area you create will be discarded.

Rotate Rotates any selections you make and can also rotate entire layers. It opens 
a dialog box in which you can set the rotation manually. Alternatively, you 
can simply click and drag the handles behind the dialog box to rotate 
by hand.

Scale Known in some other image editors as “transform,” lets you resize the 
selection area or layer. It presents a dialog box where you can enter 
numeric values, or you can click and drag the handles to resize by hand.

Shear Lets you transform the image by shearing it. Slant a selection by 
clicking and dragging the corners of the selection area (if the 
selection area isn’t square, a rectangular grid will be applied to it 
for the purposes of transformation).

Perspective Lets you transform a selection by clicking and dragging its four corners 
and independently moving them without affecting the other corners. In 
this way, a sense of perspective can be emulated.

Flip Flips a selection or image so that it is reversed on itself, either horizontally 
(click) or vertically (Ctrl-click).

Text Click the image to add text.

Bucket Fill Fills a particular area with solid color or pattern, according to the color 
or pattern selected in the color box or fill type box below.

Blend Creates a gradient fill based on the foreground and background colors. 
Just click and drag to add the fill.

Pencil Lets you draw individual pixels when zoomed in, or hard-edge lines 
when zoomed out. Simply click and drag to draw freehand, and hold 
down Shift to draw lines between two points.

Paintbrush Lets you draw on the picture in a variety of brush styles to create artistic 
effects. A brush can also be created from an image, allowing for greater 
versatility.

Erase Rather like the Paintbrush tool in reverse, deletes whatever is underneath 
the cursor. If layers are being used, the contents of the layer beneath 
will become visible.

Airbrush Like the Paintbrush tool, in that it draws on the picture in a variety of 
styles. However, the density of the color depends on the length of time 
you press the mouse button. Tap the mouse button, and only a light 
color will appear. Press and hold the mouse button, and the color will 
become more saturated.

Table 20-1. GIMP Image-Editing Tools (Continued)

Tool Description of Use
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Directly beneath the image-editing tool icons, on the left, is an icon that shows the 

foreground and background colors that will be used when drawing with tools such as the 

Paintbrush. To define a new color, double-click either the foreground (top) or background 

(bottom) color box. 

Beneath these icons, you’ll see the various options for the selected tool. The brush 

selector lets you choose the thickness of the brushstrokes and patterns that are used with 

various tools. Simply click each to change them. By using the buttons at the bottom of the 

window, you can save the current tool options, load tool options, and delete a previously 

saved set of tool options. Clicking the button on the bottom right lets you revert to the 

default settings for the tool currently being used (useful if you tweak too many settings!).

Next to the toolbar window is the Layers dialog box. You can close this if you wish, and 

reopen it later by selecting Dialogs ➤ Layers.

Ink Like the Paintbrush tool, except that, rather like an ink pen, the faster 
you draw, the thinner the brushstroke.

Clone Allows you to copy one part of an image to another via a brush. The 
origin point is defined by Ctrl-clicking.

Healing Typically used to remove unwanted irregularities, such as pimples, scars, 
and blemishes in a person’s face. Ctrl-click an ideal source similar to 
the area that needs to be healed, and then draw over the blemish, which 
will disappear. Effectively, the Healing tool is a Clone tool that has some 
intelligence built in to aid intermixing of the sample area and the area 
you’re drawing over.

Perspective Clone Similar to the Clone tool, but also allows you to take into account 
perspective within the picture. For example, you might want to clone 
a person standing in the foreground of a picture so she appears to 
be standing near a tree at the back of a photo. She should be smaller 
because of perspective, which you can accomplish with this tool. Click 
and drag the perspective bars at the corners of the image to roughly 
match the perspective within the picture (the depth), click the 
Perspective Clone tool, and Ctrl-click to select the area you want to 
clone. Then draw where you want the cloned material to appear. 

Blur/Sharpen Clicking and drawing on the image will spot blur or sharpen the image, 
depending on the settings in the tool options area, in the lower half of 
the toolbar.

Smudge As its name suggests, clicking and drawing with this tool will smudge 
the image, rather like rubbing a still-wet painting with your finger.

Dodge/Burn Lets you spot lighten and darken an image by clicking and drawing on 
the image. The results depend on the settings in the tool options part of 
the window.

Table 20-1. GIMP Image-Editing Tools (Continued)

Tool Description of Use
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The Basics of GIMP

After you’ve started GIMP (and assigned it a virtual desktop), you can load an image by 

selecting File ➤ Open. The browser dialog box offers a preview facility on the right side of 

the window.

You will probably need to resize the image window so that it fits within the remainder 

of the screen. You can then use the Zoom tool (see Table 20-1) to ensure that the image 

fills the editing window, which will make working with it much easier. Alternatively, you 

can click the Zoom drop-down list in the lower-left of the image window. 

You can save any changes you make to an image by right-clicking it and selecting File ➤ 

Save As. You can also print the image from the same menu.

Before you begin editing with GIMP, you need to be aware of some essential concepts 

that are vital to understand in order to get the most from the program:

Copy, cut, and paste buffers: Unlike some Windows programs, GIMP lets you cut or 

copy many selections from the image and store them for use later. It refers to these 

saved selections as buffers, and each must be given a name for future reference. A new 

buffer is created by selecting an area using any of the selection tools, then right-clicking 

within the selection area and selecting Edit ➤ Buffer ➤ Copy Named (or Cut Named). 

Pasting a buffer back is a matter of right-clicking the image and selecting Edit ➤ Buffer ➤ 

Paste Named.

Paths: GIMP paths are not necessarily the same as selection areas, although it’s nearly 

always possible to convert a selection into a path and vice versa (right-click within the 

selection or path, and look for the relevant option on the Select menu: Select ➤ To 

Path or Select ➤ From Path). In general, paths allow the creation of complex shapes, 

rather than the simple geometric shapes offered by the selection tools. You can also 

be more intricate in your selections, as shown in the example in Figure 20-4. Paths 

can be saved for later use. To view the Paths dialog box, right-click the image and 

select Dialogs ➤ Paths.

■Tip  Getting rid of a selection or path you’ve drawn is easy. In the case of a path, simply click any other 

tool. This will cause the path to disappear. To get rid of a selection, using any selection tool, quickly click once 

on the image, being careful not to drag the mouse while doing so.
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Figure 20-4. Paths allow for more elaborate and intricate selections, such as those that 

involve curves.

Layers: In GIMP (along with most other image-editing programs), layers are like 

transparent sheets of plastic that are placed on top of the image. Anything can be 

drawn on each individual transparent sheet, and many layers can be overlaid in order 

to create a complicated image. Layers also let you cut and paste parts of the image 

between them. It’s also possible to apply effects and transformations to a single layer, 

rather than to the entire image. The Layers dialog box, shown in Figure 20-5, appears 

by default, but if you closed it earlier, you can open it again by right-clicking the 

image and selecting Dialogs ➤ Layers. The layers can be reordered by clicking and 

dragging them in the dialog box. In addition, the blending mode of each layer can be 

altered. This refers to how it interacts with the layer below it. For example, its opacity 

can be changed so that it appears semitransparent, thereby showing the contents of 

the layer beneath.
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Figure 20-5. Set the opacity of various layers by clicking and dragging the relevant slider in 

the Layers dialog box.

Making Color Corrections

The first step when editing most images is to correct the brightness, contrast, and color 

saturation. This helps overcome some of the deficiencies that are commonly found in 

digital photographs or scanned-in images. To do this, right-click the image and select 

Colors. You’ll find a variety of options to let you tweak the image, allowing you a lot of 

control over the process.

For simple brightness and contrast changes, selecting the Brightness-Contrast menu 

option will open a dialog box where clicking and dragging the sliders will alter the image. 

The changes you make will be previewed on the image itself, so you should be able to get 

things just right.

Similarly, the Hue-Saturation option will let you alter the color balance and the strength 

of the colors (the saturation) by clicking and dragging sliders. By selecting the color bar 

options at the top of the window, you can choose individual colors to boost. Clicking the 

Master button will let you once again alter all colors at the same time.
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The trouble with clicking and dragging sliders is that it relies on human intuition. This 

can easily be clouded by a badly calibrated monitor, which might be set too dark or too 

light. Because of this, GIMP offers another handy option: Levels. 

To access the Levels feature, right-click the image and select Colors ➤ Levels. This 

presents a chart of the brightness levels in the photo and lets you set the dark, shadows, 

and highlight points, as shown in Figure 20-6. Three sliders beneath the chart represent, 

from left to right, the darkest point, the midtones (shadows), and the highlights within the 

picture. The first step is to set the dark and light sliders at the left and right of the edges of 

the chart. This will make sure that the range of brightness from the lightest point to the 

darkest point is set correctly. The next step is to adjust the middle slider so that it’s roughly 

in the middle of the highest peak within the chart. This will accurately set the midtone 

point, ensuring an even spread of brightness across the image.

Figure 20-6. The Levels function can be used to accurately set the brightness levels across 

an image.
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A little artistic license is usually allowed at this stage, and depending on the effect you 

want in the photo, moving the midtone slider a little to the left and/or right of the highest 

peak might produce more acceptable results. However, be aware that the monitor might 

be showing incorrect brightness or color values.

Cropping and Healing

After you’ve adjusted the colors, you might want to use the Crop tool to remove any extra-

neous details outside the focus of the image. For example, in a portrait of someone taken 

from a distance away, you might choose to crop the photo to show only the person’s head 

and shoulders, or you might separate a group of people from their surroundings, as shown 

in Figure 20-7.

Figure 20-7. You can use the Crop tool to remove any irrelevant details surrounding the 

subject of your photo.

You might also want to use the Healing tool to remove facial blemishes. Start by using 

the Zoom tool to close in on the area. If the blemish is small, you might need to zoom in 

quite substantially. Then try to find an area of skin that is clear and from which you can 
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copy. Ctrl-click that area. Then click and draw over the blemish. The crosshair indicates 

the area from which you’re copying. 

Sharpening

One handy trick that can improve your photos is to use the Sharpen filter. This has the 

effect of adding definition to the image and reducing any slight blur caused by camera 

shake or poor focusing. To apply the Sharpen filter, right-click the image and select Filters ➤ 

Enhance ➤ Sharpen. 

As shown in Figure 20-8, a small preview window will show the effect of the sharpening 

on the image (you might need to use the scroll bars to move to an appropriate part of the 

image). Clicking and dragging the slider at the bottom of the dialog box will alter the 

severity of the sharpening effect. Too much sharpening can ruin a picture, so be careful. 

Try to use the effect subtly.

Figure 20-8. Sharpening an image can give it better definition, but keep checking the preview.

The Sharpen filter is just one of many filters you can apply in GIMP, as explained in the 

next section.
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Applying Filters

Like other image-editing programs, GIMP includes many filters to add dramatic effects 

to your images. Filters are applied either to the currently selected layer or to a selection 

within the layer. To apply a filter, right-click the image and choose the relevant menu 

option. If you don’t like an effect you’ve applied, you can reverse it by selecting Edit ➤ 

Undo, or by pressing Ctrl+Z.

The submenus offer filters grouped by categories, as follows:

Blur: These filters add various kinds of blur to the image or selection. For example, 

Motion Blur can imitate the effect of photographing an object moving at speed with a 

slow shutter. Perhaps the most popular blur option is Gaussian Blur, which has the 

effect of applying a soft and subtle blur.

Enhance: The Enhance effects are designed to remove various artifacts from an image 

or otherwise improve it. For example, the Despeckle effect will attempt to remove 

unwanted noise within an image (such as flecks of dust in a scanned image). The 

Sharpen filter discussed in the previous section is located here, as is Unsharp Mask, 

which offers a high degree of control over the image-sharpening process.

Distorts: As the name of this category of filters suggests, the effects here distort the 

image in various ways. For example, Whirl and Pinch allow you to tug and push the 

image to distort it (to understand what is meant here, imagine printing the image on 

rubber and then pinching or pushing the surface). This category also contains other 

special effects, such as Pagecurl, which imitates the curl of a page at the bottom of the 

picture.

Light and Shadow: Here, you will find filters that imitate the effects that light and 

shadow can have on a picture, such as adding sparkle effects to highlights or imitating 

lens flare caused by a camera’s lens.

Noise: This collection of filters is designed to add speckles or other types of artifacts to 

an image. These filters are offered within GIMP for their potential artistic effects, but 

they can also be used to create a grainy film effect—simply click Scatter RGB.

Edge-Detect: This set of filters can be used to automatically detect and delineate the 

edges of objects within an image. Although this type of filter can result in some inter-

esting results that might fall into the category of special effects, it’s primarily used in 

conjunction with other tools and effects.

Generic: In this category, you can find a handful of filters that don’t seem to fall into 

any other category. Of particular interest is the Convolution Matrix option, which lets you 

create your own filters by inputting numeric values. According to GIMP’s programmers, 

this is designed primarily for mathematicians, but it can also be used by others to 

create random special effects. Simply input values and then preview the effect.
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Combine: Here, you’ll find filters that combine two or more images into one.

Artistic: These filters allow you to add paint effects to the image, such as making it 

appear as if the photo has been painted in impressionistic brushstrokes or painted on 

canvas. Figure 20-9 shows an example of applying the Oilify filter for an oil painting effect.

Figure 20-9. The Artistic effects can be used to give images an oil painting effect.

Map: These filters aim to manipulate the image by treating it like a piece of paper that 

can be folded in various ways and stuck onto 3D shapes (a process referred to as 

mapping). Because the image is treated as if it were a piece of paper, it can also be 

copied, and the copies placed on top of each other to create various effects.

Render: Here, you’ll find filters designed to create new images from scratch, such as 

clouds or flame effects. They obliterate anything that was previously underneath on 

that particular layer or within that selection, and the original image has no bearing on 

what is generated by the filter.
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Web: Here, you can create an image map for use in a web page. An image map is a 

single image broken up into separate hyperlinked areas, typically used on a web page 

as a sophisticated menu. For example, an image map is frequently used for a geograph-

ical map on which you can click to get more information about different regions.

Animation: These filters aim to manipulate and optimize GIF images, which are 

commonly used to create simple animated images for use on web sites.

Alpha to Logo: These filters are typically used to create special effects for text. They 

are quite specialized and require an in-depth knowledge of how GIMP works, partic-

ularly the use of alpha channels.

Decors: These filters are used to add decorations and special effects to an image. 

Filters include Coffee Stains (which actually adds coffee stains to your image), Old 

Photo, Round Corners, and Bevel Borders.

■Tip  If you like GIMP, you might be interested in Beginning GIMP: From Novice to Professional by Akkana 

Peck (1-59059-587-4; Apress, 2006). This book offers a comprehensive, contemporary, and highly readable 

guide to GIMP.

GIMPSHOP

GIMP is one of the most powerful programs available for Linux, but not everyone is enamored of its user 

interface. A bone of contention for some is that GIMP uses almost completely different terminology from 

that used by Adobe Photoshop. 

One developer became so annoyed by this that he created a new version of GIMP called GIMPshop 

(www.gimpshop.com). This is ostensibly exactly the same as the GIMP program, but the names of the 

tools have been changed to match those of Photoshop (or the simpler Photoshop Elements program). In 

a similar way, many of the GIMP’s right-click menu entries have also been changed so that they’re iden-

tical to Photoshop’s menu options. 

The freedom to adapt programs in this way is one of the benefits of open source software. The ability to 

take program code and create your own version is the foundation of Linux.

GIMPshop isn’t available via Synaptic Package Manager, but the Linux version offered for download 

at the GIMPshop web site can be installed under Ubuntu. Once you’ve downloaded the package, see 

Chapter 29 to learn how software installation works under Ubuntu. 
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Summary
In this chapter, we’ve taken a look at working with images under Ubuntu. This has involved 

an examination of one of the best programs available for the task under any operating 

system, GIMP, but first we started by looking at the F-Spot photo manager tool. F-Spot 

lets you easily import pictures, catalog them, and make some adjustments. Then you 

learned how to get started using GIMP to edit your images.

In the next part of the book, we move on from multimedia to look at another core 

component of Ubuntu: the OpenOffice.org suite, which provides word processing, 

spreadsheet, presentation, and other functions.


